WIN10 + MSYS Issue: Setting NuttX & SDK Configuration Fails after Dev Machine Reboot



  • I've observed this issue on two completely separate WIN10+MSYS installs (one my corporate laptop, the other my own home machine). I had successfully installed Spresense SDK within the MSYS envt, built the examples, and flashed to the Spresense board with success. The next day, after shutting down my machines and then rebooting this AM, the NuttX & SDK configuration failed(tools/config.py --kernel release). I am now receiving the following error on both machines:

    <EDIT: Added complete error msg after first attempt>

    $ tools/config.py --kernel release
    sh: kconfig-tweak: command not found
    sh: kconfig-tweak: command not found
    sh: kconfig-tweak: command not found
    make[1]: *** [Makefile.unix:300: include/arch] Error 1
    make: *** [Makefile:308: olddefconfigkernel] Error 2
    Post process failed. 512
    Try 'make distcleankernel' first.
    
    
    
    

    I followed the error msg instructions but no improvement (and yes, ran source ~/spresenseenv/setup in terminal) Also ran make clean, pulled down latest from repo, etc. I am rather stumped, I did nothing more than cleanly shutdown both PC's and reboot the next day. I am suspecting something didn't persist in MSYS. I found a similar question on a Japanese Stack Overflow post, but no one has replied:

    https://ja.stackoverflow.com/questions/55880/windows用sdkのmakeでエラーが出る

    Overall I was really impressed with how well the initial install and demo programs ran. Was moving to integrate Eclipse and ran into this.....



  • Made some progress with the SDK setup, albeit on Ubuntu and not MSYS. MSYS remains unresolved. It appears the "source ~/spresenseenv/setup" command only worked once in my MSYS install, after that the builds would fail no mater how many times I ran the command. My experience with the Ubuntu install & setup seems to support that theory (below)

    Ubuntu Notes: Setup Ubuntu 18 VM, installed SDK, built/ran "hello" example. Restarted VM, then encountered same error message as before. Realized I did not run "source ~/spresenseenv/setup" command. Ran that command and then the entire build process. Build was successful. If I do not run the "source ~/spresenseenv/setup" command the build produces the same error as noted in the first post (which is aligned with the SDK install instructions from Sony).

    I am not marking this as fixed, but for the time being I will just work from the VM. If anyone cares, it also appears the build process in Ubuntu, even as a VM, is much faster than MSYS. Just wanted to add that performance note in case someone got stuck in MSYS, and was debating going through the "hassle" of using a VM....

    As stated before, I am remain very impressed with Sony's effort w/regards to the software support for Spresense. The detailed documentation available and easy installation are a huge accomplishment IMO. Looking forward to advancing through the examples and building my application.....


  • DeveloperWorld

    Hi @Cameron-R-MANN,

    Regarding WIN10 + MSYS, try deleting these folders:

    • ~/spresense/nuttx/include/arch
    • ~/spresense/nuttx/arch/arm/src/board

    Then run "make distclean". I hope it will help!



  • @KamilTomaszewski: Your instructions resolved the issue. I can now build within MSYS without error 👍